FAQ  •  Register   •  Gallery •  Login

It is currently Sat Oct 25, 2014 2:03 am

Is my TFM-15CB really dead...?

<<

rhimbo

Newbie

Posts: 3

Joined: Thu Dec 27, 2012 4:42 pm

Post Thu Dec 27, 2012 6:08 pm

Is my TFM-15CB really dead...?

Hello folks,

Carver CT-23 pre-amplifier/tuner
TFM-15CB power amplifier

I fear one of my two TFM-15CB amplifiers has "died....." Now, when I turn on the tuner/pre-amp and amp units, I get no sound out of my speakers. If I hook up my second amp everything works fine.

For about a month leading up to the failure, I noticed that there was some delay between the time I turned on the rig and the time sound emanated from the speakers. This period increased from about a minute to about 2 hours before total failure.

There is no "pilot error" of which I'm aware. That is, the speaker select button is properly set, the input level knobs are set to maximum, and the unit has power (the power meters light up).

What do you think? Is my amp just dead?

I'm wondering how/why it died. I don't know if others in my house have turned the unit on/off too frequently (I set this up for my mom to listen to, and she is wont to turn the unit off when not actively listening).

Many thanks in advance....
<<

kingman

User avatar

(pair of) SILVER-7 TUBE AMPs

Posts: 5720

Joined: Sun Nov 30, 2008 2:10 pm

Location: Upstate South Carolina

Post Thu Dec 27, 2012 6:32 pm

Re: Is my TFM-15CB really dead...?

What do you think? Is my amp just dead?

...YES!!!!!
I'm wondering how/why it died.
...Because it's OLD!!!!! You need a repair service to go through it.
In reality, it only matters what it sounds like to YOU!!!
<<

mbskeam

User avatar

SILVER-7t

Posts: 1984

Joined: Mon Jan 25, 2010 2:32 am

Location: Woodinville Wa

Post Thu Dec 27, 2012 10:46 pm

Re: Is my TFM-15CB really dead...?

most likely the caps are going bad, there is one in the protection circuit, when it goes bad the output relay does not kick in.
this is most likely why it started taking more and more time to latch up.
if you can solder these amps are very simple to recap, maybe 15 bucks in parts
Mbskeam


#1 BLACK BEAUTY's made by the man, the myth, the legend Bob Carver
CARVER: TFM-75, TFM-45(3), SD/A-490T
SUNFIRE: Tube pre
2 sets of ALS'3, set of SILVERS, set of PLATS
AUDIOCONTROL: phase coupled activator
KENWOOD: BASIC M2a (2)

“Youth ages, immaturity is outgrown, ignorance can be educated, and drunkenness sobered, but stupid lasts forever.”
― Aristophanes

The only thing I'll feel......will be the RECOIL
Necronomicon Ex-Mortis....... Klaatu Barada Nikkto
"We should seek the greatest value of our action"
<<

cring08

User avatar

TFM-35

Posts: 489

Joined: Fri Jul 30, 2010 7:50 am

Location: Cincinnati,OH

Post Fri Dec 28, 2012 8:11 am

Re: Is my TFM-15CB really dead...?

I'm not sure where you are located, but here's one in Cincinnati.

http://cincinnati.craigslist.org/ele/3361589468.html
Chris

Living Room/main System:
Sunfire TGP IV
Sunfire 300x2
Carver Amazing Silvers
Apple tv
Carver SD 390t
Technics SL 1950 Turntable

Basement/system 2:
Carver MXR-130
Teac reel to reel
Musical Fidelity X-10D tube buffer
BBE 362 Sonic Maximizer
Nikko eq2
Cerwin Vega HED's
Klipsch SW15
Infinity RS10's
Pioneer 100 disk changer

Garage system:
Pioneer VSX something?
Polk Audio 2500
<<

rhimbo

Newbie

Posts: 3

Joined: Thu Dec 27, 2012 4:42 pm

Post Fri Dec 28, 2012 2:35 pm

Re: Is my TFM-15CB really dead...?

mbskeam wrote:most likely the caps are going bad, there is one in the protection circuit, when it goes bad the output relay does not kick in.
this is most likely why it started taking more and more time to latch up.
if you can solder these amps are very simple to recap, maybe 15 bucks in parts



Yes indeed I can solder!! But perhaps I should get a diagnostic service to determine that the caps are in fact the problem....

Given the age of this equipment, is it worth repairing? I mean, are there still audio places that would know how to diagnose this equipment? I'm in Southern California....

Thanks....
<<

angelod307

SILVER-7 TUBE AMP

Posts: 2724

Joined: Sat Jun 06, 2009 10:56 pm

Location: manning, sc

Post Fri Dec 28, 2012 3:02 pm

Re: Is my TFM-15CB really dead...?

there is not that many, replace them all. all electrolytics in the power supply, audio path ,etc. i did it and i think it was less than a dozen total.
CarverFest: I just go for the arts and crafts
<<

cring08

User avatar

TFM-35

Posts: 489

Joined: Fri Jul 30, 2010 7:50 am

Location: Cincinnati,OH

Post Fri Dec 28, 2012 4:37 pm

Re: Is my TFM-15CB really dead...?

What speakers are you using?

Maybe it's time to step up the power! :-k :-k

I know I don't regret it! \:D/ \:D/
Chris

Living Room/main System:
Sunfire TGP IV
Sunfire 300x2
Carver Amazing Silvers
Apple tv
Carver SD 390t
Technics SL 1950 Turntable

Basement/system 2:
Carver MXR-130
Teac reel to reel
Musical Fidelity X-10D tube buffer
BBE 362 Sonic Maximizer
Nikko eq2
Cerwin Vega HED's
Klipsch SW15
Infinity RS10's
Pioneer 100 disk changer

Garage system:
Pioneer VSX something?
Polk Audio 2500

Return to CARVER Equipment Repair/Help Forum

Who is online

Users browsing this forum: No registered users and 2 guests

cron
Powered by phpBB © 2011 phpBB Group.