C4000 Caps help!

If you have Carver repair questions, or can help other users with repairs, this is the place for it
Post Reply
nadude98
Newbie
Posts: 10
Joined: Mon Nov 02, 2009 11:13 pm

C4000 Caps help!

Post by nadude98 » Mon Mar 28, 2016 9:01 pm

Carver C4000 help... I was recapping my C4000 and I ran into something that seemed not right. On the peak unlimiter schematic it show's both C7's as being 4.7uf 6.3v, but on my actual board they were both 2.2uf with one being 50v and the other being 63v.

Can someone tell me for sure what the correct caps are.. I have heard that there were many versions. However everything else on the board matched the schematic in the service manual I downloaded from here.

User avatar
radioeng2
SILVER-7 TUBE AMP
Posts: 2701
Joined: Fri Jan 26, 2007 7:06 pm
Location: E TN

Re: C4000 Caps help!

Post by radioeng2 » Mon Apr 04, 2016 11:45 am

Welll...I have nothing on that particular unit. But in general it's not a big problem to up the voltage...that is until you run into size issues. I'd look for what the voltages are in the circuit to see what it should be for voltages. Going from a 6.3 to a 63 is a bit excessive though if that's the situation. Even in the factory, they'd probably up the voltage if necessary rather than wait for more stock maybe.

On the values, that'd be something more important and would take some more specific information to figure out which it should be.

Sorry, I don't know anything more on that situation. Good luck with it though!

Mark
I was there "At the Fest!" Hope you were too!

Post Reply

Return to “CARVER Equipment Repair/Help Forum”