Thank you, James!

Carver Research Forum, Everything Lightstar, Lightstar, Lightstar,
Post Reply
User avatar
BlueMDPicker
Newbie
Posts: 43
Joined: Wed Jun 13, 2007 5:50 pm
Location: Sarasota, FL

Thank you, James!

Post by BlueMDPicker » Sat Sep 21, 2013 12:05 pm

Carver_Research_Lightstar_Reference_.JPG
Carver_Research_Lightstar_Reference_.JPG (216.29 KiB) Viewed 2923 times
My beloved Lightstar Reference amp (number 003) ceased output recently. All I could imagine was this 80 pound pristine treasure having to make a jarring coast-to-coast-to-coast journey for repairs. Thankfully, I PM'ed James for some insights and he graciously took time from Carverfest to supply the info I needed to work around the issue. I am listening to it sing as I type. WOW! What an amp! I can't thank James enough for the help. You just can't beat Carver audio enthusiasts.

The workaround fix is shown in the mid right of center of the photo below. Thanks also to Dr. Bob for including that simple piece of circuitry. Whew!
Lightstar_Reference_front_panel_switch.JPG
Lightstar_Reference_front_panel_switch.JPG (103.86 KiB) Viewed 2925 times

User avatar
Snoop65
SILVER-7 TUBE AMP
Posts: 2708
Joined: Mon Jun 28, 2010 9:04 pm
Location: A galaxy far far away

Re: Thank you, James!

Post by Snoop65 » Sat Sep 21, 2013 11:13 pm

What was the cause and what was the fix?

User avatar
BlueMDPicker
Newbie
Posts: 43
Joined: Wed Jun 13, 2007 5:50 pm
Location: Sarasota, FL

Re: Thank you, James!

Post by BlueMDPicker » Sat Sep 21, 2013 11:21 pm

Cause = relay from front panel touch switch inoperable.
Fix = turn off/bypass front panel touch switch with internal slider.

User avatar
Snoop65
SILVER-7 TUBE AMP
Posts: 2708
Joined: Mon Jun 28, 2010 9:04 pm
Location: A galaxy far far away

Re: Thank you, James!

Post by Snoop65 » Sat Sep 21, 2013 11:38 pm

From one Lightstar owner to another thanks!!! Hopefully I will never have to usoe the bypass.

Post Reply

Return to “Carver Research (Lightstar)”